[BUG] [OSX] SpectrumAnalyzer falls down and other problems with 3.2 gamma

stephane ducasse (home) ducasse at iam.unibe.ch
Sun Apr 14 13:09:03 UTC 2002

hi John

Tell me where I'm wrong:
I took all the pluggin from ftp://st.cs.uiuc.edu/Smalltalk/Squeak/3.2gamma/

put them in the same folder that the VM and the image and I tried but the 
sectrum analyzer fall down after 2 s.


On Sunday, April 14, 2002, at 02:03  AM, John M McIntosh wrote:

>> I tried also to load some Mpeg but this was not working. Is it a problem 
>> with this VM?
> As far as I've been told, this should work ok. Ensure you are using the 
> right plugin for the right VM. Also the plugin must be in the same folder 
> as the VM.
> Dump some diagnostics to confirm the plugin is actually loading.
> At 8:59 PM +0200 4/13/02, stephane ducasse (home) wrote:
>> I started to convert all my demo material on 3.2. I started to use Mac 
>> OSX,
>>  3.2gamma (4811), and VM Squeak 3.2.6Beta8. I got the following problem:
>>  the spectrumAnalyzer just starts to work really slowly then blocks 
>> completely the system.
> Out of curiosity I did go and look to see if there is a malloc leak. 
> Apple's tools report no such issue. I ran it for a while and didn't see 
> anything abnormal. However I suspect there is something afoot, once I 
> tried it and Morphic got real slow and locked up.
> However I suspect this points to a smalltalk issue. Also check to see if 
> the data coming back in the buffers isn't zero. There have been some 
> reported issued with the underlying api and it fails to return results.
> -- --
> =========================================================================
> ==
> John M. McIntosh <johnmci at smalltalkconsulting.com> 1-800-477-2659
> Corporate Smalltalk Consulting Ltd.  http://www.smalltalkconsulting.com
> =========================================================================
> ==

More information about the Squeak-dev mailing list