Problem with Socket under Linux...

goran.hultgren at goran.hultgren at
Mon Apr 29 13:33:26 UTC 2002

Ian Piumarta <ian.piumarta at> wrote:
> Goran,
> I ran your test program and saw precisely what you described.
> If you managed to build from source then could you apply the following
> patch, recompile and try to reproduce your original problem with Comanche?

I downloaded your latest source from your site (4478), applied the patch
to that (instead of the SF sources which I used the last time) and first
tried my simple test program I posted - which worked fine as you also

Then I tried our app but that fails. The effect I am seeing is that the
semaphores don't get signalled when there is data (it's the
waitForDataUntil: that just sits there).

Using the ProcessBrowser (I just love you Ned! :-) I can signal the
semaphore "manually" and then my code reads the data (which sortof
proves it was there) and everything works. (Note: I am running both
server and the client in the same image but in different Processes)

> (Running your test program with these changes, my VM sits at 0% CPU [plus
> or minus a few percentage points when opening notifiers ;-] throughout.  
> I've run several other tests and the changes seem fine, but I've not run

Hmmm. Perhaps I need to pack up another testsnippet that shows the
current problem...

regards, Göran

More information about the Squeak-dev mailing list