SqueakMap project visability

Marco Paga mail at marco-paga.de
Fri Apr 4 13:56:43 UTC 2003


I got what you mean, but should the filter for all installed packages 
"overlay" in some way the other filter for new versions? perhaps changing the 
layout of th epackage loader a bit to be a bit more user firendly.

marco

On Friday 04 April 2003 15:01, Daniel Vainsencher wrote:
> You are. Browsing the code can dissipate worlds of anxiety (though it
> might take some looking to find the right thing to browse).
>
> SMLoader>>packageList
>
> 	^(self packages) select: [:e | self filter allSatisfy: [:currFilter |
>
> 		(self perform: currFilter) value: e]]
>
> You can see the filter definitions in the "filters" category of the same
> class.
>
> Daniel
>
> Marco Paga <mail at marco-paga.de> wrote:
> > -----BEGIN PGP SIGNED MESSAGE-----
> > Hash: SHA1
> >
> > Hmm. I really don't understand one option: "display new or newer
> > packages". I had to use this together with the option: "display installed
> > packages". Showing just installed packages should show me the SPrevayler
> > package if it is on my system no matter the other option (whatever it
> > should mean), or am i missing a very important point?
> >
> > regards
> > marco
> >
> > On Friday 04 April 2003 09:51, goran.hultgren at bluefish.se wrote:
> > > Marco Paga <mail at marco-paga.de> wrote:
> > > > -----BEGIN PGP SIGNED MESSAGE-----
> > > > Hash: SHA1
> > > >
> > > > On Thursday 03 April 2003 16:24, Marcus Denker wrote:
> > > > > On Thu, Apr 03, 2003 at 04:14:32PM +0200, Marco Paga wrote:
> > > > > > -----BEGIN PGP SIGNED MESSAGE-----
> > > > > > Hash: SHA1
> > > > > >
> > > > > > sorry but: nope, I can't see it.
> > > > >
> > > > > Maybe this is because you use 3.4gamma? The Package loader
> > > > > only shows the packages that are registerd for specific
> > > > > versions (in this case 3.4, 3.5, 3.6). Maybe 3.4gamma is
> > > > > not recognized as 3.4?
> > > >
> > > > it must be the package loader of 3.4gamma. I worked aorund with every
> > > > possible configuration, but my package seems not to be there.
> > >
> > > Eh, are you sure? I mean, *really* sure? :-) The reason I ask is
> > > because I see it but I *did* have to look for it - since it is called
> > > "SPrevayler" instead of "Sprevayler" it sorts itself right after "SM
> > > Package Loader".
> > >
> > > regards, Göran
> >
> > - --
> > Marco Paga, mail at marco-paga.de , http://www.marco-paga.de
> > GnuPG Key ID: 0xCD8E7612
> > -----BEGIN PGP SIGNATURE-----
> > Version: GnuPG v1.0.7 (GNU/Linux)
> >
> > iD8DBQE+jWxqlI77o82OdhIRAoMMAJ9WkFfGdLV8JvymjuwFh8IoUynEkACg0DPy
> > MNHQMg6y1INZicY0H0lHZYg=
> > =7jvq
> > -----END PGP SIGNATURE-----

-- 
Marco Paga, mail at marco-paga.de , http://www.marco-paga.de
GnuPG Key ID: 0xCD8E7612



More information about the Squeak-dev mailing list