Squeak on Zaurus 5500SL

Doug Mair dmair at columbus.rr.com
Fri Apr 18 16:57:51 UTC 2003

Re: Squeak on Zaurus 5500SLFrom what I am finding out, the Zaurus 5500SL is a different machine than the one Yoshiki Ohshima's instructions work for.

I did get Squeak running on my Zaurus with Dynapad using the instructions found at:
    and some help from the squeak-dev list

I was pleasantly surprised to find that this version actually has morphic running.  I wasn't expecting that.

Now I will have to learn the gesture interface so that I can bring up halos using a stylus, etc.

Who'da thought you could actually graphically program on a handheld computer.

Doug Mair
  ----- Original Message ----- 
  From: Alan Kay 
  To: The general-purpose Squeak developers list 
  Cc: Yoshiki.Ohshima at acm.org 
  Sent: Friday, April 18, 2003 1:45 PM
  Subject: Re: Squeak on Zaurus 5500SL

  Yoshiki Ohshima has this running. He can tell you more.




  At 11:33 AM -0400 4/18/03, Doug Mair wrote:
    I bought a Zaurus 5500 and am now trying to get Squeak running on it.

    I checked out the DirectFB Zaurus page on the swiki.

    The problem is that I don't know Linux (Unix) at all.  I'm a windows programmer with a strong DOS background.

    I copied the following files into the CF card of the Zaurus:
            squeak, dynapad-r01.image, dynapad-r01.changes

    I then booted into the OS and moved to the correct directory on the Zaurus:

    The Linux ls command showed all of the files that I expected.

    When I try the command shown on the page:
            squeak -calibrate -rotate -memory 10m dynapad-r01.image
    I get the following error:
            squeak not found.

    I also tried:
            squeak -calibrate -rotate -memory 10m Squeak.image
    and got the same error.

    I seem to remember (from my college days using Unix) that I have to set up a file as executable before I try to execute it.

    I would appreciate more specific directions about Squeak on Zaurus 5500 or Linux OS commands.

    Doug Mair



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20030418/e710b566/attachment.htm

More information about the Squeak-dev mailing list