[ENH] GraphicalDictionaryMenu improvements

Scott Wallace scott.wallace at squeakland.org
Mon Nov 10 21:41:37 UTC 2003


Hi, Stephane,

Yes, "GraphicalDictionaryMenu" was an unfortunate choice as a class 
name (***) -- a place-holder that somehow survived for many years.

Attached is a updated version of a set of enhancements I circulated 
for this tool earlier this year.  It considerably improves usability, 
so I suggest that anyone wishing to move the tool forward might want 
to incorporate these improvements:

*  'Find again' command added.
*  'Browse symbol references' command added, to browse all references 
to the key symbol of the currently-selected entry.
*  'Browse string references' command added, to track down all 
methods with string literals that may refer to the currently-selected 
entry.
*  The tool's main menu now has a 'stay-up item'.
*  The last keyword searched for is used as the default for 'find...'
*  When there is no new match in a search, but the current item does 
match that search, the tool flashes rather than claiming no match.
*  Querying the StandardScriptingSystem for a form at a given key no 
longer needlessly interns the key if it's not already interned.

Cheers,

  -- Scott


***  Provenance of the name:  It's a tool that operates on a 
Dictionary whose values are graphical objects -- forms -- and 
instances of its *superclass*, GraphicalMenu, actually do serve as 
"menus" allowing the user to choose an alternative graphic for 
SketchMorphs.


At 6:48 PM +0100 11/9/03, ducasse wrote:
>On Dimanche, nov 9, 2003, at 20:03 Europe/Zurich, 
><diegogomezdeck at consultar.com> wrote:
>
>>    |dict methods|
>>    dict := Dictionary new.
>>    methods := MenuIcons class selectors select: [:each |  '*Icon' match:
>>each asString].
>>    methods do: [:each | dict at: each put: (MenuIcons perform: each)].
>>    GraphicalDictionaryMenu openOn: dict withLabel: 'MenuIcons'
>>
>>
>>Hey! What a nive piece of code! I didn't know the existence of
>>GraphicalDictionaryMenu.
>
>What a bad name :)
>I refactor it a bit because Dictionary was dependent of it (yes).
>the next step would be to change its name.
-------------- next part --------------
Skipped content of type multipart/appledouble


More information about the Squeak-dev mailing list