Trying to compile a new VM

Julian Fitzell julian at
Fri Jan 9 20:32:17 UTC 2004

Can some kind soul give me an up to date list of resources for compiling 
a new VM?

If I use the trunk on SF CVS, I don't have any of Ian's 3.6-g-2 speed 

If I use Ian's 3.6-g-2 source, with Ned's patch to sq.h, it still won't 
run new images

Then I moved to using Ned's branch from SF CVS.,  I think it worked with 
the new images at first, but it seemed slower than 3.6-g-2.  I tried 
using Ian's preconfigured VM building image but it didn't improve the 
speed - I never seemed to be able to get better than about half the 
speed of Ian's 3.6-g-2 binary.  The only difference I can see (aside 
from the new platform sources) is my gcc 3.3.3 to Ian's 3.3.1.  Am I 
missing some compile options or is something in CVS really making it 
that much slower?

The other problem then turned out to be that the older VMMaker in Ian's 
image seemed to produce a VM that wouldn't run the new images.  So I 
need to go back up to the newest VMMaker, but Ian has patches applied 
againt the old one and I have no idea whether I still need to apply 
those or not.  And I also have no idea how new an image I need to be 
using to build the new VM.

And finally, this generated source compiles fine on Linux but appears 
not to compile on Solaris (and I've compiled the 3.6-g-2 sources on the 
same Solaris box just fine).  I don't know if this is a problem with 
Ned's branch or with the old VMMaker (I haven't yet tried a Solaris 
compile of a ned-branch/new VMMaker source tree).  The error I get is:

gnu-interp.c: In function `primitiveResponse':
gnu-interp.c:16425: `primitiveIndex' undeclared (first use in this function)
gnu-interp.c:16425: (Each undeclared identifier is reported only once
gnu-interp.c:16425: for each function it appears in.)
gmake[1]: *** [gnu-interp.o] Error 1
gmake: *** [vm/vm.a] Error 2

So does anybody know what combination of 
image/source/plugins/patches/etc I need to use to actually get a fast 
and working VM?  (and do we have a plan to post a working VM release 
sometime?  I assume Ian is just unavailable at the moment, but we really 
need to make it easier for people to test the alpha image...)



More information about the Squeak-dev mailing list