Trying to compile a new VM

Ned Konz ned at
Sat Jan 10 02:48:56 UTC 2004

On Friday 09 January 2004 12:32 pm, Julian Fitzell wrote:

> Then I moved to using Ned's branch from SF CVS.,  I think it worked with
> the new images at first, but it seemed slower than 3.6-g-2.  I tried
> using Ian's preconfigured VM building image but it didn't improve the
> speed - I never seemed to be able to get better than about half the
> speed of Ian's 3.6-g-2 binary.  The only difference I can see (aside
> from the new platform sources) is my gcc 3.3.3 to Ian's 3.3.1.  Am I
> missing some compile options or is something in CVS really making it
> that much slower?

I haven't noticed that. On the same 3.6-5424 image:

Ian's 3.6g-2 as distributed 
0 tinyBenchmarks
 '181174805 bytecodes/sec; 5002948 sends/sec'
 '180918727 bytecodes/sec; 5002948 sends/sec'
 '179271708 bytecodes/sec; 4915728 sends/sec'

Mine from CVS
0 tinyBenchmarks
 '209321340 bytecodes/sec; 7353818 sends/sec'
 '208638956 bytecodes/sec; 7205162 sends/sec'
 '209836065 bytecodes/sec; 7209717 sends/sec'

My compile options were, as I recall, the defaults (that is, -O2 
-fomit-frame-pointer -DLSB_FIRST=1). I'm using gcc 3.3.2.

> And finally, this generated source compiles fine on Linux but appears
> not to compile on Solaris (and I've compiled the 3.6-g-2 sources on the
> same Solaris box just fine).  I don't know if this is a problem with
> Ned's branch or with the old VMMaker (I haven't yet tried a Solaris
> compile of a ned-branch/new VMMaker source tree).  The error I get is:
> gnu-interp.c: In function `primitiveResponse':
> gnu-interp.c:16425: `primitiveIndex' undeclared (first use in this
> function) gnu-interp.c:16425: (Each undeclared identifier is reported only
> once gnu-interp.c:16425: for each function it appears in.)
> gmake[1]: *** [gnu-interp.o] Error 1
> gmake: *** [vm/vm.a] Error 2

I don't think there are that many changes in the source. I do think that you 
want a new VMMaker.

More information about the Squeak-dev mailing list