Trying to compile a new VM

Julian Fitzell julian at
Sat Jan 10 03:14:53 UTC 2004

Ned Konz wrote:
> On Friday 09 January 2004 12:32 pm, Julian Fitzell wrote:
>>Then I moved to using Ned's branch from SF CVS.,  I think it worked with
>>the new images at first, but it seemed slower than 3.6-g-2.  I tried
>>using Ian's preconfigured VM building image but it didn't improve the
>>speed - I never seemed to be able to get better than about half the
>>speed of Ian's 3.6-g-2 binary.  The only difference I can see (aside
>>from the new platform sources) is my gcc 3.3.3 to Ian's 3.3.1.  Am I
>>missing some compile options or is something in CVS really making it
>>that much slower?
> I haven't noticed that. On the same 3.6-5424 image:
> Ian's 3.6g-2 as distributed 
> 0 tinyBenchmarks
>  '181174805 bytecodes/sec; 5002948 sends/sec'
>  '180918727 bytecodes/sec; 5002948 sends/sec'
>  '179271708 bytecodes/sec; 4915728 sends/sec'
> Mine from CVS
> 0 tinyBenchmarks
>  '209321340 bytecodes/sec; 7353818 sends/sec'
>  '208638956 bytecodes/sec; 7205162 sends/sec'
>  '209836065 bytecodes/sec; 7209717 sends/sec'
> My compile options were, as I recall, the defaults (that is, -O2 
> -fomit-frame-pointer -DLSB_FIRST=1). I'm using gcc 3.3.2.

I have the same ones, it seems.  I also notice that I was on crack in 
one respect.  The VM I was using before was compiled by me form Ian's 
source, it wasn't his binary.  Not sure how I got that confused because 
I originally assumed it was from source but something else convinced me 
otherwise.  Using his binary, I see:

New patched VM with gcc 3.3.3:
0 tinyBenchmarks
'86486486 bytecodes/sec; 4801876 sends/sec'
'86603518 bytecodes/sec; 4801876 sends/sec'
'86195286 bytecodes/sec; 4753307 sends/sec'

The same patched VM compiled with gcc 3.0.4:
0 tinyBenchmarks
'121557454 bytecodes/sec; 5825747 sends/sec'
'121442125 bytecodes/sec; 5825747 sends/sec'
'121673003 bytecodes/sec; 5820937 sends/sec'

Ian's Binary (egcs 2.91.something):
0 tinyBenchmarks
'176066024 bytecodes/sec; 5913720 sends/sec'
'176673567 bytecodes/sec; 5913720 sends/sec'
'177162629 bytecodes/sec; 5898874 sends/sec'

So my new one is slower than them all.  And the gcc 3.3.1 must have been 
my own (It was about 220 million bc/sec and 7.8 million s/sec).  Seems 
like gcc 3.3.3 may just be making slow, slow VMs.  Perhaps 3.3.1 is just 
the magic version - I'll try to figure out how to get debian to roll 
back to 3.3.1 sometime when I have time and finish the test.


More information about the Squeak-dev mailing list