edw at generalmagic.at
Thu Jan 22 12:50:40 UTC 2004
Michael Roberts wrote:
> so how tight should the semantics be? We have both conversion and 'sub-string' behaviour.
I personally vote for a more rigid, conversion behavior.
I even lean towards that '123abc' asInteger should raise an error.
The "substring" seems still useful, it could be named like
extractInteger, parseInteger, findInteger or something similar.
Just my humble 2c
More information about the Squeak-dev