ObjectiveCPlugin progress

Marcel Weiher marcel at metaobject.com
Wed Jun 2 08:42:37 UTC 2004

Success!  Didn't change a thing, except having VMMaker already loaded.  
This time, the "initializing..." progress bar didn't even appear long 
enough to be noticeable, the various tests worked and I started playing 
around with the browser after putting the nib in the right place.

Third time lucky?   (Versions were exact same ones you mentioned, all 
freshly downloaded)

Now I'll play around with it some more....I see you are using the 
threaded model...interesting...but it's so wonderful to finally have 
this in place!



On 2 Jun 2004, at 02:41, Avi Bryant wrote:

> On Jun 1, 2004, at 3:58 PM, Marcel Weiher wrote:
>> OK, loading this from the repository gets me an error about a 
>> dependency that needs to be resolved "SmartSyntaxInterpreterPlugin", 
>> which I can't find in a fresh 3.7 beta image.  Googling reveals that 
>> this was a proposed rename of "TestInterpreterPlugin", which I can't 
>> find either, nor the "SmartInterpreterPlugin" that was suggested as a 
>> better idea.
> SmartSyntaxInterpreterPlugin is part of VMMaker.  But you're right 
> that if you don't need to build the plugin, you can proceed through 
> that warning.
>> So I tried loading it anyway, which proceeds, takes quite some time 
>> in downloading/installing and then seems to grind to a halt 
>> completely in initializing.  Does this simply take a long time?  Or 
>> do I need to resolve that reference?  Or something else?
> Hm, it went by relatively quickly for me (the actual load does take a 
> while because of all the convenience stubs for FoundationKit and 
> AppKit methods).  I tried it on a fresh 5923 image, with the Squeak 
> 3.7b-5 VM and the ObjectiveCPlugin already installed.
> Which versions are you using?
> Avi

More information about the Squeak-dev mailing list