3.7a on Linux: A few install notes and problems

Milan Zimmermann milan.zimmermann at sympatico.ca
Mon Jun 14 13:27:02 UTC 2004


After a while I found time to get back to playing with Squeak, and yesterday  
tried to install Squeak 3.7 beta on SuSE 8.2 from this site:


I used the RPM versions of "3.7b-5 Unix VM", "Squeak3.7b-5868.image" and

Providing I am not misunderstanding something, I have two notes on the 
installation: First it is confusing that user has to manually
unzip the "Squek*.changes.gz" and "Squeak*.image.gz" AFTER the installation .. 
second that perhaps a start-squeak.sh should be provided.

To start Squeak I run 

/usr/lib/squeak/3.7b-5/squeak /usr/lib/squeak/squeak.image

Squeak starts, and after clicking on "The Worlds of Squeak" project, the 
maximized project shows, but after that:
    - Games and 3D projects are empty - is that expected?
    - When clicking on the "Graphics" project, everything freezes.

I tried to update to a newer image to see if some of the above would be fixed, 
but do not know how to do it ... as well perhaps the fact that the "Games" 
and "3D" priojects are empty has something to do with the "base vs. complete 
image" but do not understand enough about it to install the "complete" image.

This may be known issues by now as the rpms are from April, but perhaps it 
helps as a "bug report",

Thanks, Milan

More information about the Squeak-dev mailing list