3.7a on Linux: A few install notes and problems

Bert Freudenberg bert at impara.de
Mon Jun 28 16:09:59 UTC 2004

Am 28.06.2004 um 11:23 schrieb muyuubyou:

> On Mon, 28 Jun 2004 11:04:02 +0200, Bert Freudenberg <bert at impara.de> 
> wrote:
>> Am 28.06.2004 um 10:05 schrieb muyuubyou:
>>> I installed the Debian packages first, and then the plug-in.
>>> Installing the plug-in broke my previous debian installation and I 
>>> had
>>> to reinstall.
>> How did you install the browser plugin? What broke? Which debian
>> packages did you use?
> I used the .debs  at INRIA. This was around 4-5 days ago (yes I'm a
> new squeaker).
> It would be best to set up a package server allowing dependencies and
> a simple apt-get install to do the whole thing, but that's another
> point.

There is. Check out Lex's stuff at 

>>> Also, first thing it asks when using the plug-in is to upgrade (from
>>> within the browser). That caught me for a while, hanging my browser.
>>> Reason: I was running the browser as non-root (for security reasons,
>>> this is a good idea, and sometimes not an option if you're running a
>>> multi-user environment).
>>> So basically you CAN'T update the plug-in if the browser is run as
>>> non-root, and the user has to figure this out
>> Yes, you CAN. ;-) In fact, this is how it was ever intended.
>> I assume you mean the popup menu from within Squeak in the browser 
>> that
>> asks if you want to install updates? That should definitely work! You
>> install the plugin as root, and it puts the plugin image under
>> /usr(/local)/lib/squeak. When you run your browser as non-root (which
>> is indeed the only sensible way to run a browser), the plugin will 
>> copy
>> the image to your $(HOME)/.npsqueak/ directory on first run. This is
>> done by the "npsqueakrun" script in the VM version subdirectory. This
>> is the image that gets updated and saved, and of course it should be
>> writable by the user.
> I run the browser (Mozilla Firefox) as non-root and didn't work. I
> tried several times. Then I tried running it as root and it worked.
> Then I switched to non-root and it didn't ask for upgrades anymore.
> Should I assume it's not using the folders it should? . Please check
> this.

I do not have a debian machine, so I can't check. What I outlined above 
is how it's supposed to work.

Hmm, it sounds like the image in your  ~/.npsqueak directory is only a 
link to the one in /usr/lib/squeak. That would explain why you could 
only write as root, and why it did not ask fot updates anymore. But 
actually it should not be a link but a copy.

You could try to delete the ~/.npsqueak directory and try with the 
browser again. Also, it may be someone fiddled with the npsqueakrun 
script ... Could you send it to me?

Also, it may be that you are running an outdated plugin version. Try 

	find /usr -name npsqueak.so -print | xargs -r ls -l

to list all references to the squeak plugin. They should be references 
to the one and only npsqueak.so in your Squeak VM directory.

> Other thing is running different versions of squeak in the same
> machine. This took me some time as well. I wanted to do this because
> a)wanted to try mini-squeak from 2.2 b)wanted 2.8 because the latest
> version has some bugs that get in the way sometimes (I want to test
> the alpha, but I also want a stable version). I'd say many people
> would want several versions running (especially developers).

Running different versions of Squeak is easy, since the latest VM works 
with all prior image versions. So you need only one VM. Just put the 
image+changes anywhere you like under your home directory, and run 
"squeak some.image". You might want to link the global Squeak sources 
file into this directory, because it still isn't found in the default 

- Bert -

More information about the Squeak-dev mailing list