ImageSegments on Linux?

Ned Konz ned at
Tue Jun 29 13:14:33 UTC 2004

On Tuesday 29 June 2004 2:12 am, goran.krampe at wrote:

> I have been busy moving over to Linux on my desktop (yay!) and just as I
> compiled my own VM (running Lunar Linux so everything is compiled from
> source on this box) and then tried to fire up SqueakMap it failed!
> It seems like ImageSegments don't want to load! The primitive fails. I
> even tested by creating a small Project, saved it on disk and tried to
> open it - same problem.
> Granted I am on a "weird platform" - Lunar Linux isn't really mainstream
> :) - and perhaps one of my optimization options for GCC creates this
> problem, but I have tested going down from O2 to O0 and some other tests
> - but no go. Any hints?

Works for me on 5963. Both saving projects in segments and saving/loading .pr 

Tried with several projects in "Worlds of Squeak".

What primitive are you talking about that is failing? I didn't know we had a 
prim for loading image segments.

Have you tried another VM?

Ned Konz

More information about the Squeak-dev mailing list