Report on the Debianized VM

Ross Boylan RossBoylan at
Tue Mar 30 08:19:29 UTC 2004

I just installed the Debianized vm as suggested on  Thanks, Lex, for your work
on this.

I had some older (3.2) Debianized packages in place; I removed them first.
I've since upgraded the sources and images debs as well, though I'm
continuing to work with my own 3.2ish image.

Basically, it went very well.  I got rid of my hardcoded VM size in my
startup script.  My virtual memory footprint is noticeably smaller,
and the system seems faster.

There is a minor documentation issue.  As I read the man page, it says
to specify drivers like "vm sound=OSS".  But the squeak --help output
suggests "vm-sound-OSS."  Perhaps both are legal (I tried both without
error messages), but it's a little confusing.

The only real problem area has been sound.  I don't have any. I'm not
sure if I did before the upgrade.  Though I have hazy memories of
having hacked my image to turn off sound, I don't have any in the
stock 3.6 image from the deb either.

I get "sound: /dev/dsp: Device or resource busy" on the terminal when
I try to use sound.  Seems like the classic problem where both want to
own the sound device; I don't know if there's an easy solution.  The
README.sound.gz (which appears somewhat dated, since it refers to
modularized sound support--available in this vm--as a possible future
improvement) did suggest a fiddle with the kernel I haven't tried, but
that fiddle seemed to be for different problems than mine.

I'm running KDE 3.1 with ALSA 1.0.2c and OSS emulation.  However,
there seem to be some problems with the latest ALSA OSS emulation; for
example, KDE will give an error if one sets it to use OSS, and I have
told it to use ALSA.

Sound's not that key for me, but I thought I'd let you know.  And it
would be nice if it worked.

P.S. My system is mostly testing, with a bit from unstable, so I
suppose that's another suspect.  However, I got the ALSA kernel
patches from unstable.

More information about the Squeak-dev mailing list