"Abstract" and "Basic" classes (was: Re: [BUG] Various packages
in Squeak 3.8 (eCompletion, Comanche, Seaside...))
brent.pinkney at aircom.co.za
Fri Apr 8 21:29:58 UTC 2005
> This raises the interesting question if we shouldn't do some renaming,
> say "AbstractString" into "String" and "String" into "ByteString". The
> reasoning being that String is a concept (that of containing characters)
> not an implementation (that of containing 8 bit latin1 encoded
> characters) and it encourages using the generalization since most people
> are used to thinking in terms of "String" modifications. Besides, I find
> names beginnign with "Abstract" or "Basic" *horrible* - it means someone
> hasn't really thought about what the name of the generalization is (or
> chosen an outright wrong name so that you have to stick the modifier in
> front of it) - can you imagine us using "AbstractCollection" instead of
> Collection, "BasicNumber" instead of Number, or "AbstractBehavior"
> instead of Behavior?
I second this - I am just about to contemplate migrating a lot of String
This is the way to go.
More information about the Squeak-dev