About squeak image compatibility (3.6/7/8)

Samir Saidani saidani at squeakfr.org
Sun Jan 8 16:21:01 UTC 2006

stéphane ducasse <ducasse at iam.unibe.ch> writes:

> We try to do our best. Really.
> We are trying to shrink the system and having some external packages.
> But as everything else this is difficult and I understand your concerns.

Hi Stéphane,

I know that you are working hard :-) ! But it doesn't explain why
adding KeyedSet, KeyedIdentitySet into Collection-Unordered ? It means
that if a newcomer use one of this class, its code will no work with
all previous squeak version ! And we can add things in the core
endlessly like that... Why don't find an agreement on what should be
standard in a common smalltalk, and thus in a standard squeak core ?
It's a pity for me to have so different smalltalk, with so different
core !

Anyway, I will see if we can package a Collection++ like which include
what it was added to Squeak 3.8 in
Collection-Unordered. (Collection-Unordered-3.8 -
Collection-Unordered-3.7 -> into the package Collection-Misc - note
that this package already exists).


More information about the Squeak-dev mailing list