Lost with Squeak development

tim Rowledge tim at rowledge.org
Fri Jan 13 02:56:08 UTC 2006

On 12-Jan-06, at 2:53 AM, Samuel Tardieu wrote:

> Today, I wanted to build an up-to-date Squeak environment for a
> GNU/Linux platform. I will explain what I have tried (so that pointers
> can be fixed if needed) and what failed. I may not have tried hard
> enough to find some things, but I think there are missing
> instructions/pointers anyway.
> I started with http://www.squeak.org/Download/. From there, I could
> not find the latest development image or any pointer to a recent
> version.
It looks to me that the various unix flavours need some more  
descriptive wording. For example, the pointer for a linux vm really  
ought to mention that it is a x86 linux build.
The unix VM Source link ought to mention it is a 3.7.7 version -  
though I'm not sure it should be there at all really as it distracts  
from what *should* be the definitive squeakvm.org site.

> I decided to start with an old 3.9a version I had around and update
> it. However, it took ages to apply patches and I recalled having read
> something about increasing socket performances in the VM, so I tried
> to update my VM first.
> By following the link on http://www.squeak.org/Download/, I landed
> onto http://squeakvm.org/unix/ and extracted the latest version from
> SVN from http://squeakvm.org/svn/squeak, as directed.
> In the platforms/unix ChangeLog I note that the last change seems to
> have taken place in March 2005. So be it, let's assume that nothing
> has changed in the VM since.
Quite a bit has as it happens. There have not been suitable updates  
on the website. I don't have access so can't provide them.

> Running "make" yields an error about the "fptr" type not being
> defined. I updated the platforms/unix/src32 directory with a fresh run
> of the latest VMMaker available on SqueakMap, and get the same error.
The latest VMMaker releases don't use or refer to fptr type so you  
certainly shouldn't be getting complaints about it.

> Obviously, something is wrong here. I remember having seen the very
> same error one year ago or so.
> Anyone knowing what's going on?
Yes - the svn unix branch is quite a lot out of date right now. I  
don't know why Ian puts copies of the generated src[32|64] dirs in  
the unix branch - it seems it can only lead to confusion. But it's  
his directory and I neither can nor will touch it. Delete that  
directory/directories and cleanly regenerate it/them.

The very latest SVN level needs some platform updates that so far as  
I know have only been applied to OSX and RISC OS as yet. David  
offered a quick patch that should at least allow compilation but may  
not provide full functionality.

A possibly simpler route is to use the VMMaker 3.8b4 release (read  
the release notes about which svn level to fetch) to make a 3.8 vm.

I would apologise for the condition of squeakvm.org but since I can't  
affect it I can't really accept any of the blame...

tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
Strange OpCodes: DO: Deadstart Operator

More information about the Squeak-dev mailing list