Squeak and bluetooth

Davide Varvello d.varvello at quinary.com
Tue Jan 17 17:51:54 UTC 2006

Hi Alain,

On 17 Jan 2006, at 14:46, Alain Fischer wrote:

> Davide,
> When you say: "The vm can find the plugin" are you sure ?

You are right, the stack trace tells: "a primitive has failed" and  
Smalltalk listLoadedModules don't show the plugin. So... what do you  
mean with: "the convention to search for a plugin is different" i.e.  
what can I change to load the plugin into a carbon vm?

> What have you used to verify this ? Smalltalk listLoadedModules ?
> Because I tried just now to put ObjectiveCPlugin in "Squeak\  
> 3.8.6Beta6.app/Contents/MacOS/"
> in "Plugins/" and in ""
> and this doesn't work I have always 'a primitive has failed'.
> This is normal since the convntion to search for a plugin is  
> different for the CarbonMac than for the UnixMac VM.
> But I just see that all seem to work nice for you wit the UnixMac VM.
> Alain
> On 17 janv. 06, at 13:55, Davide Varvello wrote:
>> Hi Alan
>>>> I don't think so, I pu the plugin in several directories one at  
>>>> a time, with no luck. The vm can find the plugin but there is an  
>>>> error during the inizialize of the ObjcBridge class. If oyou are  
>>>> interested I can send you the SqueakDebug.log
>>> My suspicion was wrong then. Where did you put the plugin in the  
>>> application directory tree when the plugin was able to load ?
>> I made three attempts:
>> 1) /Users/davide/Squeak3.7
>> 2) /Users/davide/Squeak3.7/Plugins
>> 3) /Users/davide/Squeak3.7/Squeak 3.7.5Beta1.app/Contents/MacOS
>> nothing works.
>> Davide

More information about the Squeak-dev mailing list