Loading the LinearAlgebraBook.morph

Lic. Edgar J. De Cleene edgardec2001 at yahoo.com.ar
Wed May 31 10:44:54 UTC 2006

Milan Zimmermann puso en su mail :

> PS: Doing "Workspace with contents" on the File Manager Linearalgebra1.morph,
> I received the error: "Invalid utf8 input detected". Then I installed your
> fixes: "EventRecorderMorph class-fromFileNamed.st" and "FileContentsBrowser
> class-browseStream.st", but after that, I still get the same error - it does
> not hurt anything in this particular case, but I wanted to mention it as I
> thought these 2 fixes would remove the problem, I am probably
> misunderstanding something.

As I said Milan, you found another 3.9 bug
The fix is the same as before
>> I do not test this case, think what following with the debugger should
>> encounter some place in what send the message setConverterForCode to upcoming
>> stream as in the example I send solve the problem.

And , well, this still is in 7033.

-------------- next part --------------
'From Squeak3.9alpha of 4 July 2005 [latest update: #7032] on 31 May 2006 at 7:38:25 am'!

!FileList methodsFor: 'own services' stamp: 'edc 5/31/2006 07:37'!
	"View the contents of my selected file in a new workspace"
	| aString aFileStream aName |
	aString := (aFileStream := directory readOnlyFileNamed: self fullName) setConverterForCode contentsOfEntireFile.
	aName := aFileStream localName.
	aFileStream close.
	UIManager default edit: aString label: 'Workspace from ', aName! !

More information about the Squeak-dev mailing list