[3.9-final-7067][SqueakMap Package Loader] Can't install AST

David T. Lewis lewis at mail.msen.com
Sun Jan 7 15:07:14 UTC 2007

On Sun, Jan 07, 2007 at 01:44:39AM -0300, Yakov Zaytsev wrote:
> I've tried to install AST from the SqueakMap with latest 
> Squeak3.9-final-7067
> Here are step I did
> 1. Opened squeak ./ Squeak3.9-final-7067.image
> 2. Opened SqueakMap Package Loader
> 3. Found AST entry
> 4. Pressed middle mouse button
> 5. Selected install
> and BOOM! Squeak exited and left me with the message "Pollable event" in 
> the terminal :(

I tried loading AST from SqueakMap into Squeak3.9-final-7067.image
on a Linux box, exactly as you described above. It worked fine,
so I think this may be a VM issue on Solaris.

> My configuration as follows
> $ uname -a
> SunOS iru 5.10 Generic_118855-14 i86pc i386 i86pc
> bash-3.00$ squeak -version
> 3.9-8 #6 Tue Oct 10 21:00:28 PDT 2006 gcc 3.4.3
> Squeak3.9alpha of 4 July 2005 [latest update: #7021]
> SunOS solaris 5.10 Generic_118844-26 i86pc i386 i86pc
> default plugin location: /usr/local/lib/squeak/3.9-8/*.so
> Squeak Image: Squeak3.9-final-7067.zip (ftp.squeak.org)

I'm not very familiar with SunOS, but I assume you are running
on a 32 bit processor and your SunOS is a 32 bit system (32 bit
pointer size), is that right? If it's a 64 bit system, there could
be some issues, for example <http://bugs.impara.de/view.php?id=5688>.

If it does turn out to be a VM issue, the vm-dev list is a good
place to follow up.


More information about the Squeak-dev mailing list