[squeak-dev] debugging PipeableOSProcess

Jimmie Houchin j.squeak at cyberhaus.us
Wed Mar 5 22:51:17 UTC 2008


I am having a very strange problem using PipeableOSProcess.

I created a method similar to below. It worked fine. Still does.

    | c d p |
    c := 'wget http://www.url.com/dir1'.
    d := '/home/jimmie/VL/dl/'.
    p := PipeableOSProcess command: c environment: nil workingDir: d
input: nil output: nil error: nil errorPipelineStream: nil.
    p closePipes

I attempted to use the same method to download repositories for other
directories on the same website. The only change was from dir1 to dir2.

Running the command in a shell with dir2 works just fine. Copying the
command from Squeak and pasting in the shell, works fine.

But when I run the method in a workspace. Squeak just sits and waits on
wget which at some point just stops. It doesn't exit or finish.

Sometimes if I kill the wget process, Squeak will resume working.
Sometimes not.

Is there a way to debug such a bizarre situation. With the Squeak UI
locked up until the method exits, I am at a loss on anything I can do.

Any help greatly appreciated.

And thanks for PipeableOSProcess. Its been interesting doing this in
Squeak as opposed to Python.


More information about the Squeak-dev mailing list