[squeak-dev] The Trunk: Kernel-mtf.454.mcz
nicolas.cellier.aka.nice at gmail.com
Thu Jun 3 19:26:54 UTC 2010
1) this looks very much like pointsTo:
2) instVarsInclude: is a bit misleading name
I presume this is kind of cobalt compatibility.
I would rather deprecate this message as soon as in. What do you think ?
2010/6/3 <commits at source.squeak.org>:
> Matthew Fulmer uploaded a new version of Kernel to project The Trunk:
> ==================== Summary ====================
> Name: Kernel-mtf.454
> Author: mtf
> Time: 3 June 2010, 8:51:28.452 am
> UUID: 744ec5f0-a005-4e29-b3c0-d76f96573393
> Ancestors: Kernel-ar.452, Kernel-mtf.421
> added ProtoObject >> instVarsInclude:, which is used by the pointer tracer fixes:
> =============== Diff against Kernel-ar.452 ===============
> Item was added:
> + ----- Method: ProtoObject>>instVarsInclude: (in category 'system primitives') -----
> + instVarsInclude: anObject
> + "Answers true if anObject is among my named or indexed instance variables, and false otherwise"
> + <primitive: 132>
> + 1 to: self class instSize do:
> + [:i | (self instVarAt: i) == anObject ifTrue: [^ true]].
> + 1 to: self basicSize do:
> + [:i | (self basicAt: i) == anObject ifTrue: [^ true]].
> + ^ false!
More information about the Squeak-dev