Multiple dispatch (Re: [squeak-dev] The Inbox: Kernel-cmm.464.mcz)
frank.shearar at angband.za.org
Sun Jun 20 20:30:17 UTC 2010
On 2010/06/20 21:47, Brent Pinkney wrote:
>> instead of the rather uglier
> or, as it is used, the rather prettier:
> selector: things
> "a single Thing, or a collection of Things."
> ^ thing asCollection inject: 0 into: [:total :n | total := total + n].
Yes, that is _rather_ prettier than what I'd written! I'll remember this
In which case, my argument in defence of #asArray isn't much of a
defence at all.
More information about the Squeak-dev