[squeak-dev] Re: SmalltalkImage current vs. Smalltalk
nicolas.cellier.aka.nice at gmail.com
Wed Mar 3 13:57:41 UTC 2010
2010/3/3 Andreas Raab <andreas.raab at gmx.de>:
> On 3/2/2010 10:14 PM, Michael Haupt wrote:
>> Am 03.03.2010 um 03:41 schrieb Andreas Raab <andreas.raab at gmx.de>:
>>> Consequently I'm going to completely ignore any forward-looking
>>> proposals and simply state that the current count is 3 votes for the
>>> first variant (Phil, David, Bert) and 1 vote for the second variant
>> here's another for "Smalltalk", then.
> That choice doesn't exist :-) You can vote for:
> a) Smalltalk class == SystemDictionary, or
> b) Smalltalk class == SmalltalkImage
> - Andreas
I vote for b).
After discussing this with Stephane Ducasse, I quite agree on this scheme:
SmalltalkImage should better be renamed System.
System soleInstance = Smalltalk.
Of course an optional bakward compatibility module would define
Smalltalk globals or Smalltalk namespace class = SystemDictionary
Maybe SystemDictionary shouldbetter be renamed Namespace to separate
the notion of System.
Then, if we are in need of separating methods, create new classes
But don't impose that in Kernel code, use methods indirections
(Smalltalk vm blah...)
This is a bit harder path than a), but lot cleaner IMO
More information about the Squeak-dev