[squeak-dev] Re: VMMaker loading uncovers a bug in MC

Igor Stasenko siguctua at gmail.com
Mon Mar 8 01:34:03 UTC 2010

I circumvented this problem, and continued..
But then somewhere on loading a FreeType package,
my image started throwing endless DNUs in display scanner.. up to the
point where it became completely
unresponsive :(

On 8 March 2010 03:09, Igor Stasenko <siguctua at gmail.com> wrote:
> I tried to load VMMaker package into latest trunk image:
> shortRunLengthAt: i from: runArray
>        "Return the run-length value from the given ShortRunArray."
>        ^((self cCoerce: runArray to:'int *') at: i) bitShift: Argument expected ->- 16
> I know, this is because of the latest fixes to parser to disallow
> space after unary minus.
> Once i fixed that and accepted the change, next thing which i met is DNU,
> because MC tries to install nil as a method into a class.
> It seems that a method which is hot-fixed is lost somewhere and
> instead, somehow MC includes nil in its methodAdditions collection :(
> Also, before that this happened with another package i tried to load,
> which containing syntax errors while loading.
> So, this error is easy to reproduce.
> --
> Best regards,
> Igor Stasenko AKA sig.

Best regards,
Igor Stasenko AKA sig.

More information about the Squeak-dev mailing list