[squeak-dev] VMMaker loading uncovers a bug in MC

Igor Stasenko siguctua at gmail.com
Mon Mar 8 03:14:05 UTC 2010

On 8 March 2010 05:00, David T. Lewis <lewis at mail.msen.com> wrote:
> On Mon, Mar 08, 2010 at 03:09:36AM +0200, Igor Stasenko wrote:
>> I tried to load VMMaker package into latest trunk image:
>> shortRunLengthAt: i from: runArray
>>       "Return the run-length value from the given ShortRunArray."
>>       ^((self cCoerce: runArray to:'int *') at: i) bitShift: Argument expected ->- 16
>> I know, this is because of the latest fixes to parser to disallow
>> space after unary minus.
> This was fixed in VMMaker-dtl.159.
>> ohh sorry for not mentioning. I used 'update-dtl.2.mcm' config for loading it.
> So I guess I need to fix the configuration map. I updated it to
> 'update-dtl.3.mcm' which hopefully takes care of the VMMaker part
> of the problem.
Everything is ok now, except that once it gets to loading a freetype,
i got 'subscript out of bounds'
and image UI become unusable, since same error happens over and over
again when rendering text.

> Dave

Best regards,
Igor Stasenko AKA sig.

More information about the Squeak-dev mailing list