[squeak-dev] VMMaker loading uncovers a bug in MC

Levente Uzonyi leves at elte.hu
Mon Mar 8 04:06:09 UTC 2010

On Sun, 7 Mar 2010, David T. Lewis wrote:

> On Mon, Mar 08, 2010 at 05:14:05AM +0200, Igor Stasenko wrote:
>> On 8 March 2010 05:00, David T. Lewis <lewis at mail.msen.com> wrote:
>>> On Mon, Mar 08, 2010 at 03:09:36AM +0200, Igor Stasenko wrote:
>>>> I tried to load VMMaker package into latest trunk image:
>>>> shortRunLengthAt: i from: runArray
>>>> ?? ?? ?? "Return the run-length value from the given ShortRunArray."
>>>> ?? ?? ?? ^((self cCoerce: runArray to:'int *') at: i) bitShift: Argument expected ->- 16
>>>> I know, this is because of the latest fixes to parser to disallow
>>>> space after unary minus.
>>> This was fixed in VMMaker-dtl.159.
>>>> ohh sorry for not mentioning. I used 'update-dtl.2.mcm' config for loading it.
>>> So I guess I need to fix the configuration map. I updated it to
>>> 'update-dtl.3.mcm' which hopefully takes care of the VMMaker part
>>> of the problem.
>> Everything is ok now, except that once it gets to loading a freetype,
>> i got 'subscript out of bounds'
>> and image UI become unusable, since same error happens over and over
>> again when rendering text.
> Eeek! I just tried loading from http://www.squeaksource.com/FreeTypePlus
> and something is definitely broken just as you describe.
> The error is in WorldState>>displayWorldSafely leading to an Array
> subscript out of bounds. It's not possible to open a debugger.

I uploaded two packages to the Inbox which (seem to be) fixing the issue. 
After evaluating this in an updated Trunk image (9634) FreeType should 
load normally:

(Installer squeak project: 'inbox')
 	install: 'Graphics-ul.117.mcz';
 	install: 'Multilingual-ul.100.mcz'.
CharacterScanner initialize.


P.S. I uploaded these to the Inbox because I'm not familiar with this 
part of Squeak at all, and there's a bit cleaner way to implement 
these fixes if they are correct.

> Dave

More information about the Squeak-dev mailing list