[squeak-dev] [ANN] Croquet OpenGL on Squeaksource (Re: Trying to load ALienOpenGL into 4.1 alpha...)

Andreas Raab andreas.raab at gmx.de
Tue Mar 23 06:04:37 UTC 2010

On 3/22/2010 7:27 PM, Lawson English wrote:
> Croquet OpenGL is dependent on all sorts of things. Have you managed to
> get Croquet working in a modernish version of Squeak/Pharo?

(you will need an updated 4.1 trunk image - I've promoted 
Form>>flipVertically to core in the process of making this package)

 From http://www.squeaksource.com/CroquetGL

The OpenGL interface from Croquet for consumption in other contexts. 
Supports OpenGL 1.4 plus extensions.

To install, first load the FFI via:

(Installer repository: 'http://source.squeak.org/FFI')
	install: 'FFI-Pools';
	install: 'FFI-Kernel';
	install: 'FFI-Tests'.

then load CroquetGL:

(Installer repository: 'http://www.squeaksource.com/CroquetGL')
	install: '3DTransform';
	install: 'OpenGL-Pools';
	install: 'OpenGL-Core'.

When everything has loaded, try the example:

	OpenGL example.

Important Windows Note:

In order to use Croquet on Windows, you must make sure your VM is set to 
support OpenGL instead of D3D by default. To do this, press F2 or go to 
the system menu, into the "Display and Sound" section and ensure the 
preference "Use OpenGL (instead of D3D" is ENABLED.

   - Andreas

More information about the Squeak-dev mailing list