[squeak-dev] Non-functional RFBServer with Squeak 4.2 all-in-one.

Lawson English lenglish5 at cox.net
Tue Feb 22 08:38:49 UTC 2011

Thanks. I double-checked my client, and the mouse itneractivity problem 
was at my end... However, I still seem to be having problems with 
keyboard input, all key-pressess seem to register as white space, even 
delete, and hot-keys don't work, period. I'm using the Chicken of the 
VNC application on the Mac, which has always worked before

When I tried to connect using the RFBClient using another 4.2 image, I 
get a blank window. If I click in that window and type randomly, I get 
error out of bound messages.



On 2/21/11 7:32 PM, Ian Piumarta wrote:
> On Feb 22, 2011, at 09:56 , Lawson English wrote:
>> Has anyone managed to get RFBServer working with the 4.2 final release?
> I just downloaded 4.2-10966, installed RFB from SqueakSource, saved the image, started a second VM on the saved image, started a RFB server in one window and a RFB client in the other.  The server image became unresponsive for a few seconds, then I was able to set an interactive password in the server control menu and connect from the VNC window in the client image.  No problems at all.  Interaction and display worked fine in both directions.
> FWIW, I just committed a few of 4.2 compatibility and cosmetic changes for the client to SqueakSource (thanks to Christopher Oliver) but they should not have affected *server* behaviour at all.
> Cheers,
> Ian

More information about the Squeak-dev mailing list