Uninstalling stuff (was Re: [squeak-dev] SqueakMap for documentation?)

Chris Cunningham cunningham.cb at gmail.com
Sat Feb 26 00:21:02 UTC 2011

2011/2/25 Göran Krampe <goran at krampe.se>:
> And finally, as you said - classes should ideally have #release ( opposite
> of initialize) methods I guess if they need to make modifications to the
> image before they get deleted. Not sure if that has ever been used for class
> side initializers - anyone care to elaborate on Smalltalk history here?

To me, at least ,#release would mean something completely different
than what you have mentioned here.  I'd much rather see a method named
something like #prepForUnload.


More information about the Squeak-dev mailing list