[squeak-dev] ReleaseBuilder package

gettimothy gettimothy at zoho.com
Thu Sep 12 22:17:13 UTC 2013

When I first ran into the issue, I saw some talk on it.

A search for "Squeak4.5 remoteString past end of file error"  will bring up references.

The error thrown is in:

    "Answer the receiver's string asText if remote files are enabled."

    | theFile |
    theFile := (CurrentReadOnlySourceFiles at: (sourceFileNumber ifNil: [ ^nil ])) ifNil: [ ^nil ].
    theFile size < filePositionHi ifTrue: [
        self error: 'RemoteString past end of file' ].
        position: filePositionHi;

The immediate callstack below looks like this:

ReleaseBuilder class (ClassDescription)>>comment
This is from Squeak4.5-12568.zip that I downloaded this afternoon from ftp://ftp.squeak.org/trunk/
(Note: same with the Squeak4.5-12641.zip that is there--I just tested it while typing this email)

I am running on Slackware Linux 64 with 32 bit compatability libs installed. The same image works fine when I boot do my dos partition and run it there.


---- On Thu, 12 Sep 2013 14:56:52 -0700 Bob Arning<arning315 at comcast.net> wrote ---- 

  On 9/12/13 5:50 PM, gettimothy wrote:
 153339913.-9097188325255487314 at zoho.com" type="cite"> I want to get to where I can write a plug-in for the VM, have the VM see it and use it, then build a release with it. (locally, of course)
 This doesn't depend on mastering the release process. "Release" here just means prettying up the image in certain ways to make it palatable to new users. The image you are using right now is fine for developing a plugin and for a local release.
 153339913.-9097188325255487314 at zoho.com" type="cite"> 
 One motivation is urrent issues with I recently posted on regarding 
       VNC client on squeak primitiive error 
       SSL tanking on WebClient 
       The bug on Squeak4.4 and 4.5 where modifying a comment and attempting to save it throws a system level exception.Bob
  You've mentioned this one before, but I never saw any details. Are others aware of this issue?
 153339913.-9097188325255487314 at zoho.com" type="cite"> These are all things I want to use for projects I am working on and I don't know how to fix them.
 ---- On Thu, 12 Sep 2013 13:21:53 -0700 Frank Shearar <frank.shearar at gmail.com> wrote ---- 
 That's from quite a while ago! Yes, it worked out, and I ended up 
 volunteering/being volunteered to get 4.4 released. You can find the 
 notes for the current release cycle at 
 I'm certainly not _opposed_ to documenting the release process in the 
 HelpBrowser. Some parts of the release process are of necessity 
 outside the image, but that's OK. 
 I'm a bit confused by the way you talk about the release process 
 though. It's not something people need to run, usually. 
 On 12 September 2013 19:15, gettimothy <gettimothy at zoho.com> wrote: 
 > Awesome. 
 > Thank you. 
 > I did a google on the Squeak Release process and found a thread (by you) 
 > here: http://forum.world.st/Squeak-release-process-td4640158.html 
 > Did that ever come to fruition? Would a HelpBrowser entry be helpful? (I 
 > will write it if so, and the information is available) 
 > The goal, is that newbs like me can get the release environment running 
 > locally and mash around a bit without bothering the experts too much. 
 > thx. 
 > ---- On Thu, 12 Sep 2013 10:31:41 -0700 Frank 
 > Shearar<frank.shearar at gmail.com> wrote ---- 
 > Right. That version's somewhere around 300 commits behind Trunk. After 
 > you update the image (open the Squeak menu in the docking bar at the 
 > top, on the far left), you will find only ReleaseBuilder. 
 > You always have local storage available, in the form of an 
 > MCCacheRepository pointing to the /your/image/path/package-cache/ 
 > directory. 
 > We really ought to push out a more up-to-date image, which requires me 
 > to finish finding out why the continuous integration update-image.st 
 > script is broken. 
 > frank 
 > On 12 September 2013 17:22, gettimothy <gettimothy at zoho.com> wrote: 
 >> Good news on the trunk! 
 >> I am confused by what you mean by 'There is no ReleaseBuilderForXdotY'. 
 >> I went here: http://ftp.squeak.org/trunk/ 
 >> Downloaded the .image and .change, then copied over an existing cogvm, 
 >> sources and stuff, fired up and browsing 
 >> ReleaseBuilder --> show hierarchy yields: 
 >> ProtoObject #() 
 >> Object #() 
 >> Behavior #('superclass' 'methodDict' 'format') 
 >> ClassDescription #('instanceVariables' 'organization') 
 >> Class #('subclasses' 'name' 'classPool' 'sharedPools' 
 >> 'environment' 'category') 
 >> ProtoObject class #() 
 >> Object class #() 
 >> ReleaseBuilder class #() 
 >> ReleaseBuilderDeveloper class #() 
 >> ReleaseBuilderFor3dot10 class #('current') 
 >> ReleaseBuilderFor3dot11 class #() 
 >> ReleaseBuilderFor4dot3 class #() 
 >> ReleaseBuilderFor4dot4 class #() 
 >> ReleaseBuilderFor4dot5 class #() 
 >> ReleaseBuilderNihongo class #() 
 >> ReleaseBuilderSqueakland class #() 
 >> Since this is the 4.5 release series, I was poking around in the 
 >> ReleaseBuilderFor4.5 to see if I could solve the image issue for you guys. 
 >> ReleaseBuilderFor4dot5 class>>prepareNewBuild hung when it tried to put my 
 >> (ahem) work up on trunk. 
 >> It was then, I thought I should modify 
 >> ReleaseBuilderFor4dot5>>releaseRepository to store my work locally. 
 >> If people commonly do that, I would like to mirror that style to keep 
 >> things 
 >> consistent. 
 >> ---- On Thu, 12 Sep 2013 07:21:23 -0700 Frank 
 >> Shearar<frank.shearar at gmail.com> wrote ---- 
 >> On 12 September 2013 14:00, gettimothy <gettimothy at zoho.com> wrote: 
 >>> Is there a best-practice for fiddling with ReleaseBuilderForXdotY ? 
 >>> I downloaded the latest trunk image so I could look at the recent 
 >>> background 
 >>> image issue and, after running ReleaseBuilderFor4dot5 
 >>> class>>prepareNewBuild 
 >>> discovered that it uses MCHttpRepository to upload to the 
 >>> source.squeak.org/trunk. 
 >>> I was going to play around with MCFileBasedRepository to save locally, 
 >>> but 
 >>> decided to ask the list first. 
 >>> Also, my apologies if I accidently clobbered /trunk 
 >> There is no ReleaseBuilderForXdotY. There is only ReleaseBuilder. 
 >> (Imagine that in a voice from Ghostbusters.) 
 >> You probably won't be able to clobber trunk. Or, if you did, it's an 
 >> administrator who's to blame, because only a few folk have commit 
 >> rights to Trunk. (Unlike Inbox, which is world-writable.) 
 >> frank 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20130912/a7367f6e/attachment.htm

More information about the Squeak-dev mailing list