[squeak-dev] Problems Running Squeak On FreeBSD 10.1

B J quarterwavevertical at gmail.com
Sat Dec 6 21:22:12 UTC 2014

On 12/5/14, David T. Lewis <lewis at mail.msen.com> wrote:
> I think that you probably have installed a VM that was compiled by someone
> working to support the FreeBSD distribution. Unfortunately we do not
> currently have a very good process for supporting those distro
> maintainers, and some of the resulting VMs have problems.
> Try loading one of the VMs available from
> http://www.mirandabanda.org/files/Cog/VM/ or
> http://www.squeakvm.org/unix/. I'm not sure if there is a Cog VM for
> FreeBSD at the moment, although I suspect one of the Linux ones would
> work.

My attempts at using a LInux version of Squeak made FreeBSD rather unhappy.

I do know that it supports LInux through some form of emulation or
supporting libraries.  I haven't tried that yet, though, with my
failures so far, I'm not optimistic.

Otherwise, try the FreeBSD VM from www.squeakvm.org/unix/, which is
> an official release of the same VM that your tried to install through "pkg
> install squeak".

FreeBSD didn't like it when I tried to build the VM from source code.

> I'm pretty sure that one of these VMs will work. If not, it's not hard to
> compile your own, so ask again and we'll give you some pointers.

There are some FreeBSD versions on that site, but they are for FreeBSD
8 which, I understand, is no longer supported.


I've got a few other ideas that I might try, but, if those don't work
out, I'll have to abandon it.
It's too bad as I quite like FreeBSD as an operating system.

More information about the Squeak-dev mailing list