[squeak-dev] No vm-display-x11 Plug-in After Building From Source On FreeBSD 10.1

B J quarterwavevertical at gmail.com
Wed Dec 17 06:51:29 UTC 2014

I decided to do a fresh installation of FreeBSD 10.1, complete with
Mate as desktop and Slim as the login manager.  I then downloaded the
necessary files using subversion and things got interesting.

I noticed after configuring the source code that there was a warning
from cmake about there not being a CMakeLists.txt file in:


Apparently, CMakeLists.txt has to be in all input directories but
earlier versions skipped it.  But, the current version of cmake
apparently won't allow it unless Policy CMP0014 is set.  I surmised
that by setting that parameter to OLD, I could get around it.

After setting that and then running "make", it appears that everything
was built.  I got no errors and some warnings, leading me to believe
that the parameter was a key factor.

The so.vm-display-X11 plug-in now exists in:


so that problem appears to be solved.  However, if I run:


it can't find it unless I specify that plug-in's location using the
"plugins" parameter to specify its path.  Now it complains that squeak
can't find a sound driver.

What do I do now?

Please advise.  Thanks.

More information about the Squeak-dev mailing list