[squeak-dev] No vm-display-x11 Plug-in After Building From Source On FreeBSD 10.1

B J quarterwavevertical at gmail.com
Thu Dec 18 03:23:31 UTC 2014


>> I noticed after configuring the source code that there was a warning
>> from cmake about there not being a CMakeLists.txt file in:
>> /root/Desktop/squeak/platforms/unix/npsqueak
> I think that is a harmless warning, so you can ignore it.

I'm not so sure.  After looking at a few files with that same name in
other directories, it might be critical to the overall installation
process.  I have the impression that it might contain code relating to
plug-ins, but I don't know right now which those might be.

>> Apparently, CMakeLists.txt has to be in all input directories but
>> earlier versions skipped it.  But, the current version of cmake
>> apparently won't allow it unless Policy CMP0014 is set.  I surmised
>> that by setting that parameter to OLD, I could get around it.
>> After setting that and then running "make", it appears that everything
>> was built.  I got no errors and some warnings, leading me to believe
>> that the parameter was a key factor.
>> The so.vm-display-X11 plug-in now exists in:
>> /root/Desktop/squeak/build/vm-display-X11
>> so that problem appears to be solved.  However, if I run:
>> /root/Desktop/squeak/build/squeakvm
>> it can't find it unless I specify that plug-in's location using the
>> "plugins" parameter to specify its path.  Now it complains that squeak
>> can't find a sound driver.


> Just install it and give it a try. Do "sudo make install", and run
> /usr/local/bin/squeak yourimage.image

The problem is that as it is, without having run "make install",
Squeak crashes and dumps a file.

> Are you doing this all under a root user ID (I notice your build
> directory is under /root)? Bad idea, but you can skip the "sudo" part
> if you are already root.

I installed this on an external HD and I'm using it purely for
testing.  By putting it on that drive, I can go ahead and break things
without trashing what I have in my "official" installation.  By
running as root, I can look directly at files and tinker with them.
Using "sudo" doesn't always let me do that.


More information about the Squeak-dev mailing list