[squeak-dev] Using libraries in FFI

Annick Fron list at afceurope.com
Wed Oct 22 12:45:34 UTC 2014

Hi Eliot,

	My problem is not with the VM, my problem is with my own library that I connect to through FFI.
I know where the libraries are !

I have tried to add them in /etc/ld.so.conf.d , that does not work.
I have tried export LD_LIBRARY_PATH, but somehow it erases some libraries needed by pharo.
I have done sudo ldconfig ...

In fact I have one library that depends from another one. 
In FFI I call one method which calls another method in the other library.
I have tried to create symbolics links in the directory …
I have checked that nm gives the right symbol with the right type ..

So I have no idea what to try now !


Le 22 oct. 2014 à 12:46, Eliot Miranda <eliot.miranda at gmail.com> a écrit :

> Hi Annick,
>     LD_LIBRARY_PATH should be set to point to the relevant directories, but this can be tricky as there is a lot if variation across Linux distros as to where libraries are kept.  The squeak script that comes with the Cog VMs extends LD_LIBRARY_PATH, so if you know where your libraries are you can use the script to find the other libraries the VM needs (c library and plugins).
> Eliot (phone)
> On Oct 22, 2014, at 2:55 AM, Annick Fron <list at afceurope.com> wrote:
>> Hi,
>> I am using a module in FFI which depends on a large library let’s say 10 dynamic .so files in a directory.
>> How is it possible to use this library without making all symbolic links ?
>> Annick

More information about the Squeak-dev mailing list