[squeak-dev] Re: vm build environment on windows

Henry Lavado henrylavado at gmx.com
Sun Oct 11 08:22:17 UTC 2015

Yes, Marcel! I just tried TortoiseUDiff and Apply Path... and this 
worked all Good. It is grinding through the compile right now.  Uh oh, 
ok, I got an error on FilePrims again:

i686-w64-mingw32-gcc -I/usr/i686-w64-mingw32/sys-root/mingw/include 
-msse2 -ggdb2 -mwindows -mdll -mwin32 -mno-rtd -mms-bitfields 
-maccumulate-outgoing-args -mstack-arg-probe -D_MT -O1 -march=pentium4 
-momit-leaf-frame-pointer -funroll-loops -fno-builtin-printf 
-fno-builtin-putchar -fno-builtin-bzero -I. 
-I../../../../spursrc/vm -I../../../../platforms/win32/vm 
-I../../../../platforms/Cross/vm -I../../../../src/plugins/FilePlugin 
-I../../../../platforms/Cross/plugins/FilePlugin -D_WIN32_WINNT=0x0501 
../../../../platforms/win32/plugins/FilePlugin/sqWin32FilePrims.c: In 
function ‘sqFileSync’:
../../../../platforms/win32/plugins/FilePlugin/sqWin32FilePrims.c:305:22: error: 
expected expression before ‘SQFile’
    return sqFileFlush(SQFile *f);
../../Makefile.plugin:165: recipe for target 'sqWin32FilePrims.o' failed
make[1]: *** [sqWin32FilePrims.o] Error 1
make[1]: Leaving directory 
Makefile:299: recipe for target 'build/vm/FilePlugin.lib' failed
make: *** [build/vm/FilePlugin.lib] Error 2



On 10/10/2015 1:56 PM, marcel.taeumel wrote:
> The, I guess, you should install 32-bit Cygwin. :) Anyway, there should be no
> need for the cygwin1.dll to run the compiled CogVM.
> Best,
> Marcel
> --
> View this message in context: http://forum.world.st/vm-build-environment-on-windows-tp4854659p4854889.html
> Sent from the Squeak - Dev mailing list archive at Nabble.com.


More information about the Squeak-dev mailing list