[squeak-dev] International text input on X11

Yoshiki Ohshima Yoshiki.Ohshima at acm.org
Fri May 6 22:53:30 UTC 2016

On Thu, May 5, 2016 at 4:34 PM, David T. Lewis <lewis at mail.msen.com> wrote:
> There is an ./images directory that contains development images, and
> a README to explain. There are also ./build.* directories for building
> various configurations.


First, I can run Squeak-5.0-All-in-One.zip.  on Pi.

I managed to compile squeak.cog.spur VM on ARM (raspberry pi).
However, when I tried to open the image in the All in One, it creates
a window but inside of it is just blank and does not do any
interaction.  I downloaded
and tried it, but it has the same problem.

I looked into the chain of shell scripts and tried a command line like:

env LD_LIBRARY_PATH=/home/pi/tmp/cogspurlinuxhtARM/lib/squeak/5.0-3692:/lib/arm-linux-gnueabihf:/lib:/usr/lib/arm-linux-gnueabihf:/usr/lib

but no avail.

Does anybody know why the all in one vm and image works but the VM I
downloaded from Eliot's site (nor the one I compiled)?

-- Yoshiki

More information about the Squeak-dev mailing list