[squeak-dev] Naming things (was Re: The Trunk: Kernel-cmm.1113.mcz)

tim Rowledge tim at rowledge.org
Fri Sep 1 17:32:38 UTC 2017

> On 01-09-2017, at 8:23 AM, Eliot Miranda <eliot.miranda at gmail.com> wrote:
> On the Pharo list Denis brings up a much more pertinent issue, whether pin status al are too generic.  Pavel suggests
>     isPinnedInMemory
>     pinInMemory
>     unpinInMemory

I’d tend to agree with Dennis; short and pithy names seem a good idea initially but rarely offer much of a clue as to what the hell the message does. Which makes reading code that uses said message less illuminating than it could be.

It’s like project & class naming. If you want your project named ‘sponson’ because it tickles your fancy to name it something to do with storage then go for it (but always be aware that names usually have many meanings - sponsons are also stability outriggers, mounting points etc) but for goodness’ sake don’t name all your classes in a similarly obtuse manner. Names should be something  that helps us.

tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
The colder the X-ray table, the more of your body is required on it.

More information about the Squeak-dev mailing list