[squeak-dev] MC 'check all packages for changes' fails because WebClient-Core-ul.116 is missing

tim Rowledge tim at rowledge.org
Tue Jan 8 22:46:02 UTC 2019

> On 2019-01-08, at 2:21 PM, Levente Uzonyi <leves at caesar.elte.hu> wrote:
> Did you download a fresh image? Unfortunately, we had two images released as 5.2 with different content.

An excellent question. I am pretty sure I had the latest but to be sure I downloaded the very latest 5.2 image and compared to the one I was using and it appears to be identical. Just to test, I used the new image to run the clean packages check on my iMac and it worked. This made me wonder about maybe the contents of package-cache, so I copied the new image to the Pi (where I had been having the problem - almost all my Squeak work is on a Pi just to keep testing the ARM cog), deleted the Pi version of package-cache and tried - no problem. I even tried the older-but-the-same image and it worked.

So, it looks like maybe there is some edge case where the contents of package-cache interferes a little. Just in case it suggests anything to a keen MC implementor, I generally have many images in a single Squeak directory and thus a single package-cache directory that all of them write to. Perhaps this has some bearing?

tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
Useful random insult:- Went to the dentist to have his cranial cavity filled.

More information about the Squeak-dev mailing list