[squeak-dev] Squeak5.2 save morph / load morph from file

David T. Lewis lewis at mail.msen.com
Sun Jan 13 15:53:24 UTC 2019

Hi Philip,

I can confirm the error, but I also see the same error when I try
to load the morph file in a freshly downloaded Squeak5.1-16553-64bit

Are you able to load the morph file back into the same image from
which it was generated?

If so, perhaps there is something that has been changed or added
to that image that would need to be added to the new squeak 5.2
image as well. This is only a guess, but maybe it will help.


On Sat, Jan 12, 2019 at 11:28:21PM +0100, Philip Bernhart wrote:
> Hi,
> I have the annoyance of not being able to load a saved
> morph from a file within squeak5.2-18229-64bit-201810190412-Linux
> which also applies to squeak5.1-16549-64bit-201608171728-Linux.
> The morph I want to load is a book morph and other morphs seem
> to be restorable.
> When I try to load it it fails with a positional stream error,
> with my humble debugging skills I tried to investigate it but
> failed in finding the cause.
> I attached the file which makes the problems, maybe someone
> with more skills can find the cause. It was originally generated
> within a fresh squeak5.1-18229-64bit-201810190412-Linux image.
> Thanks,
> Philip

More information about the Squeak-dev mailing list