[squeak-dev] Squeak5.2 save morph / load morph from file

Philip Bernhart philip.bernhart at posteo.de
Sun Jan 13 17:43:01 UTC 2019

Hi David,

I tried to do an export / import again in the original
squeak5.1-16549-64bit-201608171728 derived image.

And it failed there too. Creating empty morphs and
saving them / reloading them also fails when restoring
them. Doing the same on a squeak5.2 image seems to be
no problem.

That's bad. As it makes it impossible? for me to migrate
objects created in an image to upgrade them to a new squeak
version (exporting them / reloading them).



"David T. Lewis" <lewis at mail.msen.com> writes:

> I can confirm the error, but I also see the same error when I try
> to load the morph file in a freshly downloaded Squeak5.1-16553-64bit
> image.
> Are you able to load the morph file back into the same image from
> which it was generated?
> If so, perhaps there is something that has been changed or added
> to that image that would need to be added to the new squeak 5.2
> image as well. This is only a guess, but maybe it will help.

More information about the Squeak-dev mailing list