[squeak-dev] [BUG] Text drag and drop to workspace unreliable

Thiede, Christoph Christoph.Thiede at student.hpi.uni-potsdam.de
Mon Aug 24 10:14:17 UTC 2020

Thanks for the feedback! :-)



Von: Squeak-dev <squeak-dev-bounces at lists.squeakfoundation.org> im Auftrag von Jakob Reschke <forums.jakob at resfarm.de>
Gesendet: Sonntag, 23. August 2020 13:48:00
An: The general-purpose Squeak developers list
Betreff: Re: [squeak-dev] [BUG] Text drag and drop to workspace unreliable

Hi Christoph,

After merging Morphic-ct.1675 and Morphic-ct.1676, it works as
expected, thank you. Without ct.1676 the source workspace is not
updated until it regains the keyboard focus, as described in the
commit message.

Kind regards,

Am Do., 20. Aug. 2020 um 18:39 Uhr schrieb Thiede, Christoph
<Christoph.Thiede at student.hpi.uni-potsdam.de>:
> Hi Jakob,
> does Morphic-ct.1675 resolve the issue for you? :-)
> Best,
> Christoph
> ________________________________
> Von: Squeak-dev <squeak-dev-bounces at lists.squeakfoundation.org> im Auftrag von Jakob Reschke <forums.jakob at resfarm.de>
> Gesendet: Sonntag, 29. Dezember 2019 21:40:19
> An: squeak-dev at lists.squeakfoundation.org
> Betreff: [squeak-dev] [BUG] Text drag and drop to workspace unreliable
> Hi,
> I just noticed that the newly introduced text drag and drop sometimes does not work when dragging text between workspaces. It has always worked until today so I suspect the culprit is among the more recent changes.
> Problem:
> When dragging the selected text from one workspace to another, sometimes an object reference is copied to the bindings of the workspace instead of pasting the text. In the target text, the newly created variable name appears instead (e. g. text3997962) as if I had dropped another non-text object.
> At least the text is not removed from the source workspace when this happens...
> Problem #2:
> It does not always happen. When dragging from a third workspace it suddenly worked and then also from the second again. Then I reset my texts back to the old state and now it is broken again.
> Expected behavior:
> The selected text from the source workspace is cut from there, and pasted at the drop hand location in the target workspace.
> Currently I have three workspaces #1, #2, #3.
> If I drag the selection from #1 to #2, it works.
> If I drag from #1 to #3 it does not.
> Dragging from #2 to #3 does not work.
> Dragging from #2 to #1 does work.
> Now dragging from #1 to #3 suddenly does work... I dragged to the start of the text this time.
> Dragging back from #3 to #1 works.
> Dragging from #1 to #3 to the end of it also works.
> Dragging back from #1 to #3.
> Resetting (Cmd+l, lowercase L) text of #3.
> Dragging from #1 to the end of #3 does not work again. Variable pasted at the start of the text.
> Repeated dragging of the same text from #1 to #3 always pastes the variable.
> Dragging to the middle of #3 works!
> Dragging the pasted text inside of #3 to the end removed the text and pasted a variable instead.
> Hypothesis: it does not work to drop the text beyond the TextMorphForEditView. And so far I might just have been lucky to always have enough blank lines at the end of my target workspace. Workspaces #1 and #2 from above contain much more text than #3 and fill the whole editing area of the workspace, so this would be consistent.
> Squeak5.3beta
> latest update: #19300
> Kind regards,
> Jakob

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20200824/b418eaa9/attachment.html>

More information about the Squeak-dev mailing list