[squeak-dev] Sound mixing makes nasty noises

Herbert König herbertkoenig at gmx.net
Fri Dec 25 13:19:05 UTC 2020

Am 25.12.2020 um 05:41 schrieb tim Rowledge:
>> On 2020-12-24, at 1:21 PM, Herbert König <herbertkoenig at gmx.net> wrote:
>> Ha, ran the script in a terminal and on each piano keypress I get:
>> sound_Start(default)
>> soundStart: snd_add_pcm_handler: Function not implemented.
> That's an error to do with some asynchronous handler stuff in alsa. I have no idea why it would fail.
> All in all this sound stuff is getting very, very, frustrating
Same on my RPi4. Audio is working except Squeak and Scratch1, same
error. So I tried my Pi2 which I haven't updated in times but mounted on
a RPi touch display -->no sound at all and no Volume control in the

Since the RPI2 I use them for Audio recording and playing and audio
measurements. They all saw an IQaudio DAC + and Digiamp so maybe that's
part of the problem. Everything always worked out of the box, just I
never used Squeak.

Maybe it has to do with the recent switch from Alsa to Pulse Audio (just
names for me) but the Pi2 should not have seen this.

Anyway I got some time so I will check the messages from Subbu and Bruce
and then just do the reverse. Use Squeak audio on Windows (Just checked,
5.3 has the nasty effects) and record with my soundcard on a Pi.

It would be cool if someone can implement Your suggestion on how to
write Squeak's audio output buffers to a file because then I could
discern if the whole mess gets created by Squeak or if the OS plays a
role too.



More information about the Squeak-dev mailing list