[squeak-dev] Squeak 6.0 alpha-20601 browsing revisions fails because of wrong class of requestor

tim Rowledge tim at rowledge.org
Tue Aug 24 17:02:30 UTC 2021

> On 2021-08-23, at 5:57 PM, Chris Muller <asqueaker at gmail.com> wrote:
> Hi Tim,
>>> I suspect some auto-magic(ally generated) stuff behind ServiceAction that makes 'browse revisions' fail in your image. It works fine in mine.
> Is it possible, at one point, you accidentally clicked "Create new
> service" 

I've never seen that so I guess not.

>>> Which method did you try to browse revisions for?
>> A variety, and mostly it either works or complains
> In my trunk image, the one's I tried worked.  Which method(s) are you
> seeing fail?

As I said, it seems random and not noticeably related to the method choice. My only (faintly plausible) guess so far is that the code detecting the active morph for getting the requester from is not as reliable as we'd want. I *do* have some occasional annoyances where the system behaves as if the cursor point has suddenly jumped away from where I think it is, and so some other window suddenly leaps to the front, or some drag action starts, or stuff like that. Maybe that's related?

> No idea.

Likewise, so far.

tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
Programmers do it bit by bit.

More information about the Squeak-dev mailing list