This might be off topic, but why &quot;To&quot;? Why not &quot;As&quot;? Being ignorant of slang might explain why I&#39;m asking:)<br><br><div class="gmail_quote">On Thu, May 13, 2010 at 8:15 PM, Igor Stasenko <span dir="ltr">&lt;<a href="mailto:siguctua@gmail.com">siguctua@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="im">On 14 May 2010 05:07, David T. Lewis &lt;<a href="mailto:lewis@mail.msen.com">lewis@mail.msen.com</a>&gt; wrote:<br>

&gt; On Fri, May 14, 2010 at 02:41:22AM +0300, Igor Stasenko wrote:<br>
&gt;&gt; Just want to share my experience working with Interpreter/<br>
&gt;&gt; interpreterProxy api using VMMaker.<br>
&gt;&gt;<br>
&gt;&gt; Make a guess (and answer quickly, in what direction each of these<br>
&gt;&gt; methods doing conversion)<br>
&gt;&gt;<br>
&gt;&gt; positive32BitValueOf:<br>
&gt;&gt; positive32BitIntegerFor:<br>
&gt;&gt;<br>
&gt;&gt;<br>
&gt;&gt; got the answer?<br>
&gt;&gt;<br>
&gt;&gt; These methods along with other xxxIntegerFor: and xxxValueOf:<br>
&gt;&gt; used most frequently in primitive conversion code.<br>
&gt;&gt; And i am really sick of such naming..<br>
&gt;<br>
&gt; If you think of a positive integer value stored in a 32-bit C variable<br>
&gt; as a &quot;positive32BitValue&quot;, and an integer object representing values<br>
&gt; in the range 0 through 4294967295 as a &quot;positive32BitInteger&quot;, then<br>
&gt; the naming seems reasonable to me.<br>
&gt;<br>
&gt; Personally, I use MemoryAccess and SlangBrowser to look at things<br>
&gt; like this in the browser and figure out what is really going on. This<br>
&gt; shows that #positive32BitValueOf: answers an integer value (twos complement<br>
&gt; 32-bit integer as in C or Fortran), and #positive32BitIntegerFor: answers<br>
&gt; an object of type SmallInteger or LargePositiveInteger.<br>
&gt;<br>
</div>That&#39;s the point, each time i wasting time on that , to make sure i<br>
using right way of conversion.<br>
I didn&#39;t thought about better naming , but i think a more revealing<br>
names would be something like:<br>
<br>
positive32BitIntToOop<br>
oopToPositiveInt32<br>
<br>
or<br>
<br>
uint32ToOop<br>
integerOopToUint32<br>
<br>
the &#39;To&#39; word is a key here, it leaves no options how to interpret the<br>
operation direction.<br>
<div><div></div><div class="h5"><br>
&gt;<br>
<br>
&gt;<br>
<br>
<br>
<br>
--<br>
Best regards,<br>
Igor Stasenko AKA sig.<br>
<br>
</div></div></blockquote></div><br><br clear="all"><br>-- <br>Casey Ransberger<br>