<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-15">
<meta name="Generator" content="Microsoft Exchange Server">
<!-- converted from text --><style><!-- .EmailQuote { margin-left: 1pt; padding-left: 4pt; border-left: #800000 2px solid; } --></style>
</head>
<body>
<meta content="text/html; charset=UTF-8">
<style type="text/css" style="">
<!--
p
        {margin-top:0;
        margin-bottom:0}
-->
</style>
<div dir="ltr">
<div id="x_divtagdefaultwrapper" dir="ltr" style="font-size:12pt; color:#000000; font-family:Calibri,Helvetica,sans-serif">
<p>I use associations with #-> quite often - for example, with Dictionary class >> #newFrom::</p>
<p><br>
</p>
<p>Dictionary newFrom: {1 -> #one. 2 -> #two}</p>
<p><br>
</p>
<p>In Contrast to #at:put:, the above version checks that each key is unique.</p>
<p><br>
</p>
<p>Best,</p>
<p>Christoph</p>
<div id="x_Signature">
<div id="x_divtagdefaultwrapper" dir="ltr" style="font-size:12pt; color:rgb(0,0,0); font-family:Calibri,Helvetica,sans-serif,EmojiFont,"Apple Color Emoji","Segoe UI Emoji",NotoColorEmoji,"Segoe UI Symbol","Android Emoji",EmojiSymbols">
<div name="x_divtagdefaultwrapper" style="font-family:Calibri,Arial,Helvetica,sans-serif; font-size:; margin:0">
<div><font size="2" color="#808080"></font></div>
</div>
</div>
</div>
</div>
<hr tabindex="-1" style="display:inline-block; width:98%">
<div id="x_divRplyFwdMsg" dir="ltr"><font face="Calibri, sans-serif" color="#000000" style="font-size:11pt"><b>Von:</b> Squeak-dev <squeak-dev-bounces@lists.squeakfoundation.org> im Auftrag von Levente Uzonyi <leves@caesar.elte.hu><br>
<b>Gesendet:</b> Montag, 16. Dezember 2019 15:52:12<br>
<b>An:</b> The general-purpose Squeak developers list<br>
<b>Betreff:</b> Re: [squeak-dev] #<-</font>
<div> </div>
</div>
</div>
<font size="2"><span style="font-size:10pt;">
<div class="PlainText">I think #-> was not a good idea. I personally use it fairly rarely, and
<br>
it's just a shorthand variant of Association>>key:value:.<br>
It was probably more useful when brace arrays were not part of the <br>
language, but I find the latter way superior for creating tuples.<br>
<br>
Levente<br>
<br>
On Mon, 16 Dec 2019, Thiede, Christoph wrote:<br>
<br>
> <br>
> Hi, thanks for your arguments!<br>
> <br>
> <br>
> I think that #<- would be symmetric to #->, such as #< and #>, etc. ...<br>
> <br>
> Another example would be [Dictionary newFrom: {1 <- #one. 2 <- #two. 3 <- #three}], but I agree, readability is quite subjective here.<br>
> <br>
> <br>
> From my point of view, Stef, implementing #<- with a completely different meaning would be confusing. I guess this depends on your specific domain.<br>
> <br>
> <br>
> @Jakob:<br>
> <br>
> > Sometimes I think one should separate Smalltalk the programming language from Smalltalk as a scripting language (in Vivide or your spreadsheets, Christoph). I find such brevity cool for the latter but I despise it for the<br>
> former.<br>
> <br>
> <br>
> Interesting statement! From a scripting perspective, it would be great to have a maximum number of convenient utils. However, I find it always confusing when you start building a solution via scripting and then need to<br>
> rephrase your code because scripting syntax is not available for real programs. This compromises the idea of the One Uniform Smalltalk.<br>
> <br>
> Best,<br>
> Christoph<br>
> <br>
> _________________________________________________________________________________________________________________________________________________________________________________________________________________________________<br>
> Von: Squeak-dev <squeak-dev-bounces@lists.squeakfoundation.org> im Auftrag von tim Rowledge <tim@rowledge.org><br>
> Gesendet: Sonntag, 15. Dezember 2019 19:59:19<br>
> An: The general-purpose Squeak developers list<br>
> Betreff: Re: [squeak-dev] #<-  <br>
> <br>
> <br>
> > On 2019-12-15, at 3:38 AM, Jakob Reschke <forums.jakob@resfarm.de> wrote:<br>
> ><br>
> > Sometimes I think one should separate Smalltalk the programming language from Smalltalk as a scripting language (in Vivide or your spreadsheets, Christoph). I find such brevity cool for the latter but I despise it for the<br>
> former.<br>
> <br>
> Also +1. What next -<br>
> 1 value: 4 value: 'two'<br>
> being handled by converting the 1 to #one, sending #isKindOf: to the second arg and then coercively converting the first argument to a compatible class via an indirection dictionary provided by a database lookup from the<br>
> receiver?<br>
> <br>
> tim<br>
> --<br>
> tim Rowledge; tim@rowledge.org; <a href="http://www.rowledge.org/tim">http://www.rowledge.org/tim</a><br>
> Useful random insult:- Ought to have a warning label on his forehead.<br>
> <br>
> <br>
> <br>
> <br>
></div>
</span></font>
</body>
</html>