MaxOS X Spoon VM grief

Craig Latta craig at
Thu Feb 24 10:02:50 UTC 2005


	Well, I can't seem to get a new MacOS X Spoon VM to run, despite being 
able to do it last February. I can build and run a vanilla VM from 
John's 3.8.6b6 sources, but when I run a VM with the Spoon changes in it 
(from ), 
on the Spoon control snapshot (from ), I get a 
crash on a bad memory access; but the Xcode debugger just shows me 
assembly, no source.

	My current motivation to build a new Spoon VM is to get faster graphics 
on MacOS X. The last one I built ( ), 
performs absurdly slowly in MVC (reported by Stéphane).

	I also tried building a MacOS X Spoon VM from Ian's "unix" sources. The 
system starts, but the Display is all-black.

	Any help anyone can offer would be wonderful. Otherwise I guess I'll 
just wait another N months, when perhaps the sources are different in 
some good way, and try again... but I'd really rather make the Mac my 
main machine.



Craig Latta
improvisational musical informaticist
craig at
[|] Proceed for Truth!

More information about the Vm-dev mailing list