Problem building from latest SNV & VMM

David T. Lewis lewis at
Fri Jul 8 19:09:40 UTC 2005

On Fri, Jul 08, 2005 at 11:32:06AM -0700, Tim Rowledge wrote:
> I can't see it either. Diffing your version of sqMemoryAccess and mine
> shows no functional difference I can see. A couple of things in
> different order, a couple of duplicated defines moved out so they don't
> need to be duplicated, a couple of extra macros that I hadn't found a
> need for.
> I don't suppose putting those things in slightly different order can
> confuse that wonderful compiler? Surely not... Does it work if you use
> the macros instead of the inline statics? It works( worked, anyway)
> both ways on RISC OS and OSX a while back.

I get similar results whether I am using the macros or the static inline
functions, and the latter have not changed since the dist3 source code.
I just attached my sqMemoryAccess.h in the interest of full disclosure,
but I don't think that it is causing the problem.

I've diffed through all the ./platforms source to compare current SVN
source to the older dist3 source, and I don't see anything that looks
wrong. Likewise, I don't see anything different in VMMaker that looks
like a problem. There are quite a few changes to the unix configure
script, so maybe there's something hidden in there that has an effect.
I just can't spot it, whatever it is.

I'm using gcc 3.3.1, which is not what Ian recommends, but I would
not expect that to be an issue given that it worked fine for me on
the older code.

Still stumped,


More information about the Vm-dev mailing list