[Vm-dev] Building Unix 3.9-8 Squeak VM On Intel Mac

Ken G. Brown kbrown at mac.com
Mon Apr 16 07:55:37 UTC 2007

Working with Craig to get the Spoon stuff working on MacIntel (MacPro 10.4.9). I installed Xcode 2.4.1 to get gdb and compilers but did the following from Terminal:

Tried compiling the Unix sources from  Squeak-3.9-8.src.tar.gz at <http://squeakvm.org/unix/> according to the HowToBuildFromSource.pdf and incorporated Todd's instructions below, and tried opening Sq-dev-beta-107.image but it hangs with 100% cpu. Have the 3.9 sources.
Also tried an older image Squeak3.7a-5905.image and V3 sources with same results.
Ideas anyone?

>For those who come after and might search the archives - I got a build of the Unix VM working on an Intel MacBook.
>Untar the source, cd to Squeak-3.7-7/platforms/unix
>config/configure --without-x   (unless you want to fiddle with not found gl.h files in the X11 display lib)
>vi vm-display-Quartz/sqUnixQuartz.m
>change #define USE_SPINLOCK 1 to 0
>make INTERP=interp
>make INTERP=interp Squeak.app
>drag the resulting Squeak-3.7-7.app into /Applications
>On Mar 28, 2006, at 11:50 PM, Todd Blanchard wrote:
>>I've got a new MacBook and want to build a native version of the Unix VM.
>>I'm stymied by the existence of powerpc assembly in sqUnixQuartz.m
>>Any hints on how to work around this?
>>Todd Blanchard

More information about the Vm-dev mailing list