[Vm-dev] cog crash when running Pharo 1.2 tests

Igor Stasenko siguctua at gmail.com
Fri Dec 31 16:03:06 UTC 2010

On 31 December 2010 16:31, Mariano Martinez Peck <marianopeck at gmail.com> wrote:
> Hi Esteban. When I run a big code with Cog (replace ALL unused compiled methods but proxies), I have the same error. At least the same 3 first lines:
> (gdb) bt
> #0  0x0008f18c in longAt [inlined] () at /Users/MAC/Desktop/Dev/VM/cog-osx/platforms/Cross/vm/sqMemoryAccess.h:41314
> #1  0x0008f18c in longAtPointer [inlined] () at /Users/MAC/Desktop/Dev/VM/cog-osx/platforms/Cross/vm/sqMemoryAccess.h:41314
> #2  0x0008f18c in mapPointersInObjectsFromto (memStart=544259160, memEnd=547015536) at /Users/MAC/Desktop/Dev/VM/cog-osx/platforms/iOS/vm/../../../src/vm/gcc3x-cointerp.c:19156
> In my case, the error is that the oop to is trying to access in longAt: is negative.
> If you continue in the stack, in my case, is while doing an incremental GC. Hopefully we are talking about the same error.

probably yes, because #becomeForward: also using same routines as in
GC for traversing object memory graph and rewriting old object
location(s) with new ones i,.e. mapPointersInObjectsFromto().

[here i get rid of overquoting]

Best regards,
Igor Stasenko AKA sig.

More information about the Vm-dev mailing list